App not opening after login

The app is not opening on my iphone. After filing in the log in details I get a blank screen with rotating wheel. I’ve had this problem for about two weeks now.

I’m using an iphone se (1st gen) os15.1.

1 Like

Hi Tim,

Working on this issue now. Re-install the app is the instant fix.

I wonderred about that but worried I will loose all the data.

Hi Tim I have had the same problem for 3 weeks, and still the same as soon as log in get the wheel going around and basically no way of getting out of it. !

HI, I haven’t plucked up courage to reinstall the app yet. Perhaps I should and let you know.


I have now reinstalled the app, after deleting it on my phone, and all seems OK.

I’ve been having this problem for several weeks now too. I’ve tried un-installing and re-installing the app a couple of times. Since the last re-install, when the spinning-wheel-of-doom stops the app just goes back to the log in page. I still can’t get past the log in to see or enter any data. I’m using a relatively up- to-date android phone.

Hi 1st time user. Having the same issues… have deleted and reinstalled App twice.
Still won’t open for me either… on a New Samsung Android System.
I am trying to encourage sceptical older folk thzt run lots of traps to use the App… so far they are less than impressed suggesting they can club a doz rats in the time we muck around with a system that doesn’t seem to want to know.

Can you sort it please ASAP.


I have the same issue. I log in with my credentials then it spins around waiting for the projects to show. I removed the App and installed it again from the Google Play store. I recently joined another project so I am curious whether it was that, but since others have had the same issue in the same timespan, I guess not. Details: Huawei y9 prime 2019 model STK-L22, EMUI build based on Android 10. Plenty of RAM and storage free. Resolution 2340x1080. I am not having any other app issues. This occurs on Wifi, 4G and 3G. I believe the previous app version worked, but I am sure we cannot go back to the old one using the google play store.



Kia ora all,

There has been a new app version released yesterday - 4.1.13 - that should fix these issues. Please try uninstalling and reinstalling today, and let us know if you’re still having issues after that.

Ngā mihi,
The Trap.NZ Team

I’ve updated the app on an iphone and now I’m stuck on the Projects screen with a spinning loading icon. As soon as I log in I get a pop saying some records failed to submit and then it’s just the blank Projects screen with the spinner.
Have deleted and reinstalled the app and now working ok.