Audio alert stops after a period of time

While using the walk the line function with audio alerts turned on (and phone at full volume) I get proximity alerts as usual, but after a period of time they stop. At first I thought I just wasn’t hearing them as they aren’t particularly loud even at full volume, but held my phone and watched the installations go green with no sound made. I’m using a Samsung S21 FE and the latest version of the app.


I would normally point people this help page for this sort of issue:

Considering your’s turned green but didn’t beep, then that might be something else.

After what period of time did you observe it stop?


Hi Andy,

Hard to say how long it went before stopping as it was quite quiet when it was working and when I wasn’t hearing it I wrote it off as my ears not picking up the noise until I properly checked. If I had to guess maybe an hour. I wondered if It was my phones settings turning off repetitive notifications after a period of time but couldn’t find any settings related to that.



If I was to hazard a convenient guess I would also say it is phone settings. Samsung are notorious for turning things off, or offering the option to turn things off, but without describing the knock on effects.

Battery optimisation is normally the culprit:

Best I can suggest it check all your volume settings, and any battery optimisations, then keep us posted if it happens again.

Sorry, not much help, but hopefully with few more clues we can figure it.


Sorry to jump in on the thread - On this link you shared Andy, it says “in some circumstances it may be more appropriate to temporarily turn off GPS servicing” but doesn’t say what those circumstances are or what turning that off actually does? Please enlighten me!

Hi Tui,

With the GPS Servicing turned off, the GPS track is still recording, but installations within range won’t be automatically serviced.

Examples of turning it off might be you’ve run out of fresh rabbit so can’t service the last 20 traps, or the weather turns bad, so you head home early. Generally you’ll want a complete record of where you went and how long it took. This gives you the opportunity to prevent the installations from being automatically serviced.

Hope that helps,

1 Like

Hi Andy,

I did another short trapline and paid more attention to the pattern. Before starting I had battery optimisation turned off. It worked fine, pinging the installations and making the notification sound.

1hr 6min into the trapline I noticed that it had stopped making the notification sound. Given the timing I suspect it stopped after an hour. I tried turning the battery mode to High Performance (rather than optimised) but that didn’t help.

Hi Andy,
I have also had this issue and have shared it on the forum once before.
I have worked out the pattern is around 20 traps and the beep disappears. If you save the line and re start the GPS Walk the line feature, you can get it to beep for another 20. As suggested above, the GPS tracking still works for the full line, its just the sound proximity alarm that gives up.