Bait details missing

HI there,

I uploaded a CSV file for traps. Although the bait details were complete on the spreadsheet, on many of the records in the report the bait details came out as “None”. I had entered dehydrated rabbit or whole egg on every line as appropriate but seemingly at random these descriptions did not go through to the report. I can’t spot any difference between the ones that worked and the ones that didn’t.



Hi Terry. Can you please send us a copy of the CSV file (email to - we’ll give it a check.

There may have been a mismatch in the bait name (it is fussy about case, spaces, etc). It looks like Dehydrated Rabbit came through but Whole egg (note the odd case) got set to None.

Note that you can change records in bulk via the manage records screen. E.g. if you need to set all the None values back to Whole egg.

I imported the new spreadsheet - sorry no luck. Also tried to change the values in bulk that didn’t work. It must be something I’m doing wrong but I just can’t see it. Maybe if we can talk on the phone I can give you my login and you can see what’s happening.


PS Maybe this is worth looking at. I’m also a member of the Pan Pac Kaweka project and in their report the bait details information is missing from a lot of records.



The problem seems to have solved itself - did you do something??

Hi - yes. There was a bit of work done on the import scripts, and also on the edit from - the form was prepopulating bait details from previous records - which was meant to help with data entry but actually not very useful (and made it look like the record had the wrong data when you went back and edited it).