Edit Lines returns website error

Steps to reproduce:
Navigate to Lines and add a new line - select a colour but do not draw any co-ordinates; save as is.
From the list of lines select the newly created line and attempt to edit it (as if to add the co-ordinate path later)
Error is displayed.

The problem does not seem to occur when a line co-ordinates have been drawn on the map at the time the line was created.

Sorry David this is not really a reply.
I’m receiving the same error on new Lines. Whether selecting a colour or not, or loading a GPX or not, I haven’t tried drawing the line co-ordinates as I have GPX files for the lines I want to add.
On a related note, I loaded a new GPX file to an existing line but the old GPX is still being displayed.
Feels like either there is a programming bug or a piece of the Line software is not interfacing with the database.

I did find a work around to delete the line and add it again but its only useful if you haven’t added lots of traps to the line, or you don’t mind adding them back again.

If you open up the line and look at the web-site address it ends in a number.
click on edit and the number stays the same and has “edit” on the end. You will see the error message but ignore it.
Change the word /edit to /delete and press enter.
You will get a warning that you are going to delete the line and any traps that are associated with it will not be deleted but won’t be associated with it any more.
You can click Delete to proceed.
Then you start again creating the line but this time draw some co-ordinates (even if they are wrong you can edit it later on)

Thanks guys - this was a known issue when adding a line without a location. It should be fixed now.