Mobile app losing bait settings

Just about everytime I use the app in the field I have to re-enter the bait settings. Any ideas how to prevent this?

Kia ora,

That doesn’t sound normal. I’d suggest you reset the app (Menu > Settings > Advanced > Reset App…)

Please keep us posted.


I’m having the same problem. I’ve reset app but it keeps showing “Still set,bait bad” and it shows on desktop that it’s “intial set”. TIA for any help and to @Pa_Hill for mentioning this :smile:

OK, I realised something strange was going on when I noticed there was no menu on my app (the ‘hamburger’ menu at the top left of the app). I deleted the app and reinstalled, everything appears to be working OK now. A week later I still have my bait settings.
I’m still not 100% sure this has solved the issue. The lack of menu also came with loss of the aerial map and new baitstations/traps not showing on the app. Loss of the aerial map occured about a month before my original post, however the loss of the bait details has been happening for much longer (more than a year)