Monitoring - Website bugs

I’ve encountered a couple of bugs while investigating the Monitoring section to evaluate it for uploading our camera data.

  • In the Add Station section, there are none of my Lines in the list for me to select.
  • In the Add Data section I cannot select which monitoring station detected the event, nor can I select any Lines
  • In Import Monitoring Records section there is no information on which Species values are allowed
  • In the App, I cannot select a species when entering a monitoring record.

If you could let me know when these bugs are fixed that would be great - we have 50+ cameras, being checked regularly and all images identified. Over 2 years this is 300,000+ detection events so I’m wanting to be sure the system can handle the data appropriately for us.

Just another user here, but I have had a play with importing data feature.
Does your browser load a box with a blue background when you visit this link? https://trap.nz/import/import_monitoring_records

The list of species is in there, but I’ll include them below just in case you have a browser issue:

Species

  • Bat
  • None
  • Lizard
  • Unspecified
  • Rat
  • Mouse
  • Ferret
  • Stoat
  • Weasel
  • Rabbit
  • Hedgehog
  • Possum
  • Insect
  • Weta
  • Bird
  • Magpie
  • Cat
  • Dog
  • Other

Thanks so much for the list - it’s good to know.

Yes I get the blue box with the field criteria, but there is no list of Species values allowed - maybe it is a browser issue, I use firefox but I’ll try it with Chrome.

Cheers,
Jake

Kia ora Jake,

I’ve had a look into your issues.

  • In the Add Station section, there are none of my Lines in the list for me to select.
    The lines in your project have all been set up as Trap Lines, so they won’t show up in the Monitoring section of your project. You can edit the Line Type by clicking through to the line from the Lines section of your project, then clicking “Edit”. Then you can edit the Line Type section:

  • In the Add Data section I cannot select which monitoring station detected the event, nor can I select any Lines
    From what I can see in your project, you have only one monitoring station set up, and it is a Camera type station. Camera monitoring stations don’t use normal records, they use photographs, so the “Add Data” section doesn’t apply. You can upload photographs to the station by clicking on the station link, then hitting the green “Upload images” button

  • In Import Monitoring Records section there is no information on which Species values are allowed
    The species list here is autofilled by your project settings. You can update the species list for your project by clicking through to “Project Categories” from your main project view:


    Then clicking through to “Monitoring Species”:
    From here you can select which species are available to your members in the Monitoring section of your project.

  • In the App, I cannot select a species when entering a monitoring record.
    This should be solved by selecting Monitoring Species as above.

Hope that helps!

Ngā mihi,
The Trap.NZ Team

1 Like

Hi Sarah,

Thanks so much for that info - it helps a great deal. So we have 53 cameras onsite, we manually identify the species captured in each image and record these data to monitor predator abundance. If the TRAP.NZ ‘camera’ monitoring station can only record images - what should we be using instead to record these data?

Kind Regards,
Jake

Kia ora Jake,

The Camera stations don’t use the “Add Data” workflow that other Monitoring Stations use on the website, as they record different data. As well as a photograph, you can select which Species you’ve ID’ed, as well as a few other options, before saving that record.

The Camera Monitoring Stations feature is a new one - it hasn’t been “officially” released (though the functionality exists on the app and the website) - so we’re still figuring out what data accompanies a record, and how to collect that in the app and the website. If you have any ideas on what other data would be useful for your group to record against your camera stations, feel free to let us know!

Ngā mihi,
The Trap.NZ Team

Kia ora Sarah, I’ve been trying to use the camera upload feature today and I am getting stuck at the upload part. I have left it for over half an hour to do one image, my colleague at a different site is experience this same issue. What should I expect to happen after the upload process? For reference this is what I’m seeing on the page. Cheers.

Kia ora Amy,

Thanks for bringing this to our attention. I have let the dev team know about this. They are going to redirect a user back to their camera page with the new photo record attached, once it is finished uploading.

At the moment the records are being saved once they are uploaded, so once that green tick appears on the image (as shown in your screenshot), you can navigate to your camera and see the new record in the list.

Ngā mihi,
The Trap.NZ Team

Thanks Sarah,

A redirect back to the camera page will be great. I have to say though, I’m not certain my record is uploaded, as when I go back to that camera page I don’t see any records. And searching in the monitoring report doesn’t produce any results.

Cheers,
Amy