My iphone won't update from the net

My iphone app went awol again and lost the trap & boundary data when off grid in April. It was there when I started but vapourised on accessing the first trap. Pretty common hassle. Updated using the PC a few days later because it easier to change date & time in that. Phone won’t load the new data or do anything else in the app except show the working on it symbol. I’ve had to abandon the app and use the PC later quite a few times before but now the app won’t load the boundaries or traps at all. Please tell me what to do to fix this. I hate the ongoing bugs in this app it completely spoils the trapping experience

Kia ora @stanb I’m sorry you’re having these issues. Have you tried resetting the app or uninstalling and reinstalling the app in between these issues?

Kia ora Stan,

This issue may have already been fixed, but it’s hard to know without having details of the app version you have installed, the phone model you are using, the project you’re on etc. You are welcome to send those details through to us via Need help? | Trap.NZ.

Version 6.0.6 is currently in open beta release and has many bug fixes which may be applicable to what you’ve experienced. You are welcome to join the testing programme, and provide feedback. Details of the bug fixes and new features, and how to join the programme are here:

Nga mihi,

iPhone 14 iOS 16.3 Trap 6.0.2. None of the help processes worked. Ie exporting the out of date logs or resetting the app

Deleting the app and reinstalling has reloaded the traps and project. Now just need to keep it going off line