Some records not syncing from phone application

Update: this is fixed from version v4.1.5

This has been happening to me, and I’m on app version 6.0.13. Any fix? I have logged in and out, synced project, pushed the cloud button on the top right-hand corner.

We have done a little work in this space on v6.0.14 and later. These are in beta testing now, and looks to be resolved. It will be released shortly.

Feel free to send us your exported logs if you’d like that one entry recorded.

I have version 6.0.18 and it’s still happening to me saying “access denied for user”

I am also having this trouble with certain random records, it looks like the troublesome ones are from a few days in June. Not a whole day’s records though.

I’m guessing this is why this project also comes up with a yellow caution sign on the main log in page on the app!

Edited to add I’m on 6.1.3, project is Te Nukuroa o Matamata and the two days with a few stuck logs are 21 and 22 June 2023

Second edit to add I just had a look on my personal phone (usually use my work phone for records but I do have the app on both) and it has some problem ones as well. I welcome any advice on how to make everything match up again!

Hi Tui,

If you can send us your logs to we can take a look at why.

Out of interest were they the initial record after the trap was installed?


Cool thanks Andy, I’ll do that.

I think so actually, I didnt open all of them but a couple I looked at were the install and initial set I’m pretty sure.

It seems to be the initial set records that have the trouble

Is anyone else still having issues with this? When we add records while out of service, they do not upload when we get back into service. We get a yellow exclamation mark, which when clicked on, does not give us the option to re-upload. It’s happening to our whole team - any ideas?

Kia ora @jenileehill can you export the JSON file and CSV file from your phone app logs to I will advise you what to do after that.

Kia ora koutou,

Sorry to dig up this ancient thread, but starting to run into this problem again.

Getting the same sort of issue I originally had, where some records don’t sync and they don’t want to retry. I’ve tried exporting the CSV and picking out the records I want to upload to the website and I noticed they had the previous days date on them in the CSV. And then when I tried to upload them to the website they came back with a ‘incorrect date’ error (sorry I don’t recall the exact error).

I’ve worked around this by just manually entering the records I want into the website, but don’t want to have to do this every time.

Thanks in advance!

Hi Jade,

I was also having this problem, but I uninstalled and reinstalled TrapNZ and it has so far fixed it the issue on 5 different phones (Samsung A10 and A34) version 6.2.23.

I jumped on here just to let TrapNZ know that I’ve been having issues and faults since the recent update.


Kia ora,
I’m having this problem too. It was happening on the previous version and again on v6.2.23.
Some records in my log have a yellow exclamation mark and upload cloud symbols and the log says Record Failed. There used to be a retry option that worked well, could this be brought back?


This help document may resolve the issue.
It may also help to reset the app afterwards here is the help doc detailing this
If neither of these work for you, please contact us via