Starting up the app when I’m not connected to the net

I asked this question some time ago and I had a problems starting the app when I’m not connected to the net. I’m using 6.0.3-beta.14. on an Android phone.

I clear traps in a remote location where there’s no network coverage and today when I was trying to use the app I couldn’t get it start up. I think I saw a message on the screen about it trying to authenticate but it flashed up and was gone too quickly to be sure and then the app shuts down so I had to try again. Same thing happened several times.

I put the phone into Flight Mode as that seems to have helped in the past but then I got the map pictures for the area but no lines or traps marked on it. All of this is quite unhelpful.

As soon as I get back to “civilization” and turn Flight Mode off it all comes good. It seems that there’s more testing need for off grid usage. I’m happy to help with that.


Kia ora,

It sounds like the app hasn’t fully download by the time you put it into flight mode.

With 6.0.3-beta.14, you shouldn’t need to put it into flight mode, unless you are trying to conserve battery. The transition from online to offline has been problematic, and 6.0.3 has a lot of changes to address that. We would be very pleased to have any feedback.

Are you able to do the test again and leave flight mode off?

Many thanks,

I’ll try next week when I’m on site.

I tried today and things worked. However my app had been upgraded to 6.0.6 in the meantime.

I’ll keep my eye on this problem as it’s intermittent and they’re the pits to debug. If I get more info I’ll pass it on.


1 Like