TRAP.NZ app missing from PlayStore?

I deleted the TRAP.NZ app from my android mobile, then tried to reload it.

I’ve searched PlayStore several times over the past few days, but the TRAP.NZ app does not appear. Suggestions please.

Try this:

thanks Oseiler

I can see the app on my computer in Play Store,, and on my husband’s phone, but not on my phone.
I wonder if I’ve inadvertently banned TRAP.NZ somehow from my phone, can’t think how though.
Oh bother!
Thanks again,

One reason for not showing on your phone could be that the app requires a specific Android version or other feature that your phone isn’t compatible with.
If you open the link I posted, while logged in with your google account, there should be a ‘install’ button in the top right corner that remotely installs it to your phone.

Kia ora Jo,

It might be that the Google Play Store thinks you’re not in NZ - this happened to me when I moved back to NZ, I couldn’t access some NZ-only apps on the Play Store, and had to work out how to change my location. It could also happen if you’re using a VPN. Do you think that might be happening for you?

Or as oseiler said, if you’ve got an old phone, the app might not be compatible, and so wouldn’t show up in the Play Store.

Hope you can get it sorted soon!

Ngā mihi,

thanks oseiler and Sarah

The phone has only ever been on a NZ network and hasn’t travelled overseas for some years, and has been working fine in NZ, so I don’t think it’s that.

It is getting old - how do I find out which Android version TRAP.NZ needs? A version of the app was working until recently when I removed it - has there been a new version of TRAP.NZ in the last month or so?

Is there a workaround, or is this an excuse for a new phone?

Many thanks,


1 Like

Hi again Jo,

If you’re already using Android 8.0 or above, please let me know what device you have. I can check it against our list of compatible devices and let you know if you’re on it or not!

Ngā mihi,

thank you both.
It’s Android 6.0.1.
So, no TRAP.NZ for me now.

I also have problems with the app.
It worked fine for a year or so but now never loads up. Only the wheel of doom going around!
I have an IPhone 11 so should be fine.
Should I uninstall and reinstall??

Kia ora,

Thanks for reaching out. Yes we do recommend uninstalling and reinstalling again if you’re having that problem. It’s a known issue with the latest version, which we are working hard to fix! If you keep having problems, please email me on with more info (screenshots are especially helpful).

Ngā mihi,