Unable to Add Catches on the Website & App

As a new user to the site it is very frustrating to use and has numerous bugs:

  1. When adding catches on the website its says ‘‘dot’ field is required’ when the Save button is selected. Its impossible to work out what the ‘dot’ field is. I have tried entering a value in all fields but still get the same message.
  2. The website doesnt allow the user to enter the bait type
  3. When adding catches on the App it says record failed “Bait type id” and illegal choice has been detected. I have tried entering bait notes and leaving the field blank but still get the same error.
  4. I couldn’t log into the site via the App although found the work around to be deleting the App and reinstalling it.

Feels like its too hard to bother recording the info…

Kia ora,

Sorry to hear the website has been so frustrating to use. It sounds like you’ve encountered some strange bugs - could you please email me on support@trap.nz, with screenshots of the error messages you’re seeing? Once we have an idea of what you’re experiencing, the tech team can take a look and see if they can find what’s wrong.

Ngā mihi,
The Trap.NZ Team

I’ve got the exact same problem

I have the same issue ref https://forums.trap.nz/t/error-bait-type-id-an-illegal-choice/6445

I have the same issue with the bait type. Doesn’t show any options and then won’t save as the field isn’t populated. Website and App.

Hi GlenroyH,

This should be fixed and I can’t replicate the issue. If you are still having issues please send the details to support@trap.nz so we can get it sorted for you;

The project
App version.