Urgent issue with map view in trap.nz phone app

I was called this morning by a fellow trapper who found she could no longer zoom into trap locations on the map in the trap.nz app. I tested from my phone and found the same issue. The map looks fine when zoomed out but when I zoom in to view the individual trap locations the screen is divided into squares and the view is completely blurred. I tried logging off and back on to the app. This did correct the view,
but only for a short period of time. After ten minutes or so the problem re-occurred. I trap in four different projects. These are ‘Northern Forest’, ‘Pauatahanui Wildlife Reserve’, ‘Pest Free Whitby’ and ‘Plimmerton’. If I switch to a different project the view is corrected, for a time, however switching back to another one shows the same zoom in issue.

Further update. As a last resort I uninstalled and re installed the app on my phone. After this zoom in views in all 4 projects are showing correctly.

  1. I’m not sure if this is permanent. I will check back in 30 mins or so to see if the views are still showing correctly.
  2. If this has fixed the problem, does this mean all users of the trap.nz app will have to uninstall and re install the app on their phone?

Kia ora @jb1 I just tried it on my phone (iPhone) and project and didn’t have to same issue are you using android or iPhone?

Sorry I should have said… I have an Android phone. I think the trapper that called me has an android phone as well. So far about 30 mins after the reinstall the zoom in function is still working. I’ll contact the other trapper asking her to re install to see if it fixes the issue on her phone.

@jb1 keep us informed.

Perhaps take a look the help section on map tiles.

If your project boundaries are massive (your’s don’t appear to be,) the 100mb tile data allocated to the whole area doesn’t go very far (i.e. it has to sacrifice the highest zoom levels to stay within 100mb)

When the tiles are downloading the app shows the tiles directly from server for the zoomed in area, but does not cache them for offline use. As soon as all the tiles for the area (up to the 100mb) are downloaded, the app will switch to using those.

This to some degree matches what you are seeing I believe.

Two options available:

  1. Up the mb limit as described in the help docs. Don’t go beyond 500mb.
  2. Turn on 'Hi-res tiles on demand via the settings, also described in the help docs.

Why a reinstalled fixed it I’m not sure, other than perhaps reseting the 100mb limit. As Lenore suggested, please keep us posted.


Hi Andy/Lenore
I’ve never changed the 100mb limit. I have asked the trapper who originally told me of the issue to reinstall and this fixed the blurring issue for her as well. I will ask some of the other users if they are seeing this problem.
However there is something I can add that may be working as designed. As I said I have four projects I trap in. If, from home, I select one of the projects the app takes me to the project area, and I can zoom in on the trap areas with no problem. If I then select one of the lines in the project and I then select Map, the area shows as Blurred, see new pic.The map shows correctly if I’m on site, I tried this yesterday when trapping. The other trapper saw this issue when she selected a line she is going to trap today. I have asked her to report back to me when she is on site to let me know if Map is working after she selects the line. Can you tell me why this is happening and is it working correctly?

Okay, I think I can now see where you’re going wrong. The example location you’ve provided above is way outside of the project boundaries. I have just tested your project on the app and can confirm that I had the same experience as you when zooming to the spot you indicated, however that is expected behaviour.

The app only downloads high resolution tiles within the project boundaries, beyond those boundaries it is only high level tiles (i.e. enough to give you some bearings.) This is very much by design.

To see this in practice, simply zoom right in anywhere within the boundaries and you’ll see high detail, but swipe a few hundred metres outside of the boundaries and it will soon become pixelated.

As per the previous answer, seeing hi-res tiles outside of the boundaries is likely to be a temporary phenomenon that happens only when the tiles are downloading (when the little earth spinning at the top.) Again this is by design and expected particularly if you’re just reinstalled the app.

Solutions are:

  1. Adjust your boundaries to fit your expected working area.
    You might want to up the mb limit as described in the help docs . Don’t go beyond 500mb.

  2. Turn on 'Hi-res tiles on demand via the settings, also described in the help docs. Note that this will only work within network coverage and use mobile data - option 1. is probably what you want if regularly outside the boundaries.

Hope that helps,

Ok Andy, I suspected there was a reason for what I was seeing there. It may explain the initial problem I reported, however then I was getting the blurring effect in all the projects I trap in without selecting a line, then map. After the re-install the blurring effect only occurred when I selected a line out my area (which you have explained). I’ll try your suggestion though,

I’ll also query some other users to see if they have any issues and let you know.

I have an iphone and an Android for our project and I used them interchangeably and do not have the issue you are describing. Simon, Predator Free Aoraki