Unable to save trap record - save button not working

Hi, today I could not get tap records to save on the app. Seems the save button wont work. I was able to add a new installation, just cannot add the records.
Tried on two different android phones. Was able to add records from the website. I have successfully added trap records in the past too.
Anyone else having this issue?

I think you may have to hold the save button down as opposed to just tapping it.

Thanks Bevan - yes I have saved records before :slight_smile: The press and hold to save is just not working today. If I tap the button it still pops up with the ‘hold down to save’ message.

Ah that sounds like an issue!

Hi TSmith,

This normally happens because a required field hasn’t been filled in. Firstly check there isn’t a error message next to one of the fields. Since you know what you’re doing I suspect that’s not the case.

Which app version are you using? Menu > About


Hi Andy,

We’re having this issue again - app version 3.4.13. Last time it came right the next day but this time it has been a few days and still not working for the team.
I have just updated the app on their phone to this version but still having the same issue.


Yes I’m having exact same issue. Work great last time round and now as soon as I enter bait info and push and hold save button it just freezes up and nothing will open

Hi there, we seem to have the issue intermittently. We found that if the user logs out of the app and then log back in again it seems to work! Might help you in the meanwhile? We check traps 2x a week so I have suggested the team log out when the last trap record has been entered for the day or if they have the issue then to log out and back in again. Seems to be working for them!

Edit - having this issue again today and the logging in and out trick is not helping us anymore! The records just wont save.

Hi Tara,

I still suspect it’s a required field not having a value, but it’s clearly not displaying the error.

I know it’s a long shot but it would be good to know if there is a pattern at all, i.e. it only happens when entering a catch, or any particular values?

Some values are persisted to the next form to make life easier. I suspect it’s one of those fields causing the issue.

I’ll take a further look at it but any more details would be great.

Thanks for notifying us,

Hi Andy,

Thanks so much for the response.

No doesn’t seem to matter, and Im pretty certain we have all fields filled in as the team have been successfully adding records for a few months.

Today I updated the phone, seemed to work but when the team member went out, he had issues saving records again (even though I had it working) so I exited the app, turned off the wifi, went back in to the app and the save function started working fine again. I started to question whether the saving issue was because the data input screen was open too long / timed out or it was only working on wifi, hopefully eliminated those possibilities now. Will let you know if the problem persists. We are using a very basic phone which is slow but does work - have been using the app for around 6 months on it.

Hi All,

We are having a similar issue. Three of our group are using android phones. When they log traps they either disappear, log in the wrong place or both. They cannot always see other traplines around them.

I’ve checked the app settings and phone settings and there doesn’t seem to be anything that would inhibit the app from working correctly.

One of our users keeps getting this error report:

Record Failed

{“name”:“NetworkError”,“statu”:406,“response”:{“form_errors”:{ög":“You must select one or more groups for this content.”}},“line”:102,“column”:206,“sourceURL”:ïndex.android.bundle"}

Appreciate any advice or help.



Hi Gerard,

Thanks for the feedback !!

The app version would be very helpful, and the project id (project name should suffice though.)

There are number of potential issues described there, with a host of potential causes. Some might be down to an old release of the app, some could be user permissions.

The first thing I’d check is that all members are activated. As in an admin has activated their account after the member asked to join the project (see the projects members page.) The error message above is symptom of a user not being activated. The app doesn’t provide a useful error message in this scenario, something we shall fix.


Hi Tara,

Sorry to leave you hanging. Are you still having issues?

I’m wondering if we could get you onto our test version for the next app release. It has a lot of performance improvements so it would be good to know if they help in your case.

Let me know and I’ll get you the details.


Hi Andy,

thanks for getting back to me. the version we are using is 3.4.13.

the project name is the ‘Kourawhero Conservation Group’’.

I’ve checked the members that are having issues and they have all been activated as members. I’m the administrator.

Any other suggestions?

Appreciate your help.


Hi All
App still freezes up after entering the bait info and pushing the save button. From there the the app is unusable and cannot enter any trap records.Phone has to be turn off to get the app to reset it self. Have tried the phones with no luck.

Hi Andy, apologies for not coming back to you earlier. Would be happy to trial the test version if you still need someone. I dont use the app myself but I help the team who do - I set it up for them to use.

We were doing well again until today, they had the issue again today but when they came to show me it worked (of course!). Often we can exit the app and restart to fix it. Seems to be quite random. The phone they’re using is very basic but seems to work most of the time.
I also test it with and without the wifi to ensure it is not an issue offline - doesn’t appear to be.

Hi Tara,

You can sign up with this link for the open beta testing:


Let me know how you get on,